Le forum pour tous les bidouilleurs electroniciens, du novice à l'expert !
 
AccueilAccueil  CalendrierCalendrier  FAQFAQ  RechercherRechercher  MembresMembres  S'enregistrerS'enregistrer  Connexion  
Bienvenue ! Des questions sur l'électronique? Ou passionnés par ce domaine? Partageons nos savoirs et compétences en vous inscrivant.

Partagez | 
 

 [Problème RÉSOLU] Capteur IR pour tachymètre

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Quentin
Admin
Admin
avatar

Messages : 419
Date d'inscription : 21/04/2012
Age : 23
Localisation : Haute-Vienne (87)
Emploi/loisirs : Collecto-bédétiste !

MessageSujet: [Problème RÉSOLU] Capteur IR pour tachymètre   Lun 13 Aoû - 11:44

Bonjour à tous !

Je me suis confectionné le petit tachymètre à affichage LCD présenté ici: http://doumai.pagesperso-orange.fr/Tachymetre_LCD/Tachymetre_LCD.htm
Le tachy en lui-même est terminé et fonctionne très bien, mais je ne m'étais pas encore occupé de la fabrication du capteur optique( http://doumai.pagesperso-orange.fr/Capteur%20Fourche/Capteur%20Fourche%20IR.htm )
N'ayant pas le C.I HEF40106 (intégrant 6 trigger de Schmitt inverseurs), j'ai voulu essayer de m'en confectionner un avec un AOP (UA741 CN) à partir de ce cours: http://electronique.aop.free.fr/AOP_sature/3_comparateur_schmitt_noninv.html

Mais le résultat n'est pas concluant, j'ai une tension de sortie très variable, ce qui ne me convient pas du tout et ne correspond pas au caractéristiques attendues (je cite: "La tension de sortie Vs ne peut qu'être égale à +Vsat ou -Vsat" )

Alors voilà le montage que j'ai fait:



à gauche, c'est la partie capteur, que j'ai remplacé par un générateur de tension (0 à 5V) pour tester mon montage avec l'AOP le plus aisément possible.
La diode en sortie était prévue pour ramener à zéro mes créneaux négatifs, mais je ne l'ai pas câblée.
Les 2 résistances réglables étaient au max afin d'avoir un rapport R1/R2=1/10, et le potar était réglé de façon à avoir environ 3,18V sur l'entrée inverseuse. Tout ceci dans le but d'avoir comme seuils de commutation Vh=4V et Vb=3V (d'après les formules fourni par le site electronique.aop.free.fr)

Et ça ne marche pas ! scratch
Aurais-je mal compris l'application de l'AOP en trigger de Schmitt ? Mon montage est-il correct ? Le choix des valeurs pour les résistances est-il adapté ?

merci pas avance ! drunken


Dernière édition par Quentin le Sam 18 Aoû - 8:28, édité 2 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://dessoudeurs-ex.lebonforum.com
Quentin
Admin
Admin
avatar

Messages : 419
Date d'inscription : 21/04/2012
Age : 23
Localisation : Haute-Vienne (87)
Emploi/loisirs : Collecto-bédétiste !

MessageSujet: Re: [Problème RÉSOLU] Capteur IR pour tachymètre   Mar 14 Aoû - 8:35

J'ai essayé avec d'autres AOP, mais rien de concluant non plus...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://dessoudeurs-ex.lebonforum.com
gregelec
Membre actif
Membre actif


Messages : 114
Date d'inscription : 01/07/2012
Age : 56
Localisation : Vivoin 72170 (Le Mans)
Emploi/loisirs : ADD/AlertGasoil

MessageSujet: Re: [Problème RÉSOLU] Capteur IR pour tachymètre   Mar 14 Aoû - 8:59

Le 741 n'est pas fait pour fonctionner en +5V -5V il lui faut au moins +-12v en plus c'est un ampli très lent pas du tout adapté à ce montage

si tu n'as pas de 40106 c'est pas grave utilise n'importe quelle porte logique en cd40xx changes la résistance de 10K par une 4.7k (celle du collecteur de l'opto)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.alertgasoil.com
Quentin
Admin
Admin
avatar

Messages : 419
Date d'inscription : 21/04/2012
Age : 23
Localisation : Haute-Vienne (87)
Emploi/loisirs : Collecto-bédétiste !

MessageSujet: Re: [Problème RÉSOLU] Capteur IR pour tachymètre   Mar 14 Aoû - 18:35

Merci Greg, c'est super ! nickel J'ai tout repris à zéro et refait des tests, ça devrait le faire. J'ai pris un CD4001 (porte NOR), le seuil de basculement des états logique est à 3V à peu près, donc c'est parfait. Il faut juste que je prenne un peu de temps pour positionner mon capteur au mieux et trouvé un bon papier réfléchissant, de façon à avoir un signal le plus propre possible et ne pas avoir de "parasite" au passage des 3V.

Merci ! bière

Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://dessoudeurs-ex.lebonforum.com
Quentin
Admin
Admin
avatar

Messages : 419
Date d'inscription : 21/04/2012
Age : 23
Localisation : Haute-Vienne (87)
Emploi/loisirs : Collecto-bédétiste !

MessageSujet: Re: [Problème RÉSOLU] Capteur IR pour tachymètre   Ven 17 Aoû - 21:13

Bonsoir à tous,

j'ai lu sur le net qu'il ne fallait pas laisser de broches "en l'air" pour les circuits CMOS. Est-ce justifié ? et si oui, faut-il que je mette les 3 broches inutilisées de mon CD4001 à la masse ? (ou autre ?) scratch
Je suis preneur d'une petite explication si vous avez le temps ...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://dessoudeurs-ex.lebonforum.com
gregelec
Membre actif
Membre actif


Messages : 114
Date d'inscription : 01/07/2012
Age : 56
Localisation : Vivoin 72170 (Le Mans)
Emploi/loisirs : ADD/AlertGasoil

MessageSujet: Re: [Problème RÉSOLU] Capteur IR pour tachymètre   Ven 17 Aoû - 21:27

oui il ne faut pas laisser une entrée Cmos en l'air car la capacité parasite de l'entrée vas se charger petit a petit et le moindre parasite ambiant risque de faire basculer l'entrée dans un état haut ou bas au grès des fluctuations donc tu les raccordes à la masse
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.alertgasoil.com
Quentin
Admin
Admin
avatar

Messages : 419
Date d'inscription : 21/04/2012
Age : 23
Localisation : Haute-Vienne (87)
Emploi/loisirs : Collecto-bédétiste !

MessageSujet: Re: [Problème RÉSOLU] Capteur IR pour tachymètre   Sam 18 Aoû - 8:27

Merci Gregelec ! nickel
Je pense que mon capteur est maintenant opérationnel ! banane
Je me suis fait un typon (avec TCI4), j’espère pouvoir me procurer le matériel nécessaire pour faire mon petit C.I la semaine prochaine. Si tel est le cas, j'en profiterai pour poster un peu dans la rubrique "réalisation de C.I". hiboux
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://dessoudeurs-ex.lebonforum.com
Contenu sponsorisé




MessageSujet: Re: [Problème RÉSOLU] Capteur IR pour tachymètre   

Revenir en haut Aller en bas
 
[Problème RÉSOLU] Capteur IR pour tachymètre
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Une règle étrange... [problème résolu merci ^^ à archiver]
» [aide][résolu] Aller/retour pour evoluer Pitrouille
» APPEL PATRIOTIQUE POUR LA SAUVEGARDE DE LA DIGNITE NATIONALE ET DE LA DEMOCRATIE
» Couleur transparente pour RPG Maker XP
» Problème avec mon avatar sur steam

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Les dessoudeurs de l'extrême :: AIDES & ASTUCES :: PROBLÈMES SUR UN CIRCUIT, UN MONTAGE, UNE RÉALISATION ?-
Sauter vers: